Forum breadcrumbs - You are here:ForumCategories: Assembly & setupMK3 setup issues
Please or Register to create posts and topics.

MK3 setup issues

Page 1 of 2Next

I am trying to get the new MK3 I built working. I had the PCBs built from the Gerber files, and flashed the Nodemcu with the precompiled BIN file. I've actually put together two of the board and cable sets to compare issues. They all act the same. If the controller is powered up without the cable connected it connects with WIFI and gives the expected sensor errors. If I plug one of the sensors in, either one, it seems to read it fine and give a connection error for the other one. When I plug both sensors in at once, then it will no longer connect at all. If the wiper of either pot is disconnected, it will connect and read the other one and give the error for the one not connected. What am I missing?


Having similar sensor issues. I've gone through the wiring several times checking and rechecking pins and it looks correct but no matter what I do it doesn't seem to see the sensors as stated on the webpage.  Were you able to find out the issue?

Hello. I have exactly the same problem. Could you find the solution?

Thank you

After checking everything several times I went back to flashing the ESP8266 module using the supplied document and it worked. What is the error coming up from the satran page after connecting to it for you?

Quote from KD9WDV on 2023-12-02, 23:07

After checking everything several times I went back to flashing the ESP8266 module using the supplied document and it worked. What is the error coming up from the satran page after connecting to it for you?

Thank you very much for your response.
Several things, when I start it, it indicates that there are no sensors (and there are).
Then I move the azimuth from the calibration page and the elevation motor moves!
The azimuth motor never moves...
Everything is correct, well connected, and checked 10 times.

I will do what you mention, load the bin again and see what happens.


Something must have happened with mine as well, I'm getting "Azimuth sensor did not register motion when initializing." EL moves during start-up but as you say AZ does not for me.  I've been troubleshooting this all day.

Also make sure you are not at the limit of the AZ pot or it may give bad readings when it first starts up.  I've been trying to find near the center so when it does initialize it doesn't go past it's limit.

Gustavo has reacted to this post.

Well, I'll comment on my progress. Incredibly, I had to change the motor connections because they were working in reverse. When I wanted to activate elevation, it activated azimuth. I still don't understand why.

Regarding the sensor issue, I had to test each potentiometer connection, deviating from the tutorial image until they worked. Satran detects the sensors.

Another problem that arose at that moment is that when it turned on and made movements, it kept going non-stop because the potentiometers were measuring in reverse. I reversed the sensor cables, and it worked perfectly.

Now I have 2 problems to solve. To calibrate, for example, the elevation, when you move to reach 0 degrees, the sensor value should increase, but it decreases. Logic would say to invert the potentiometer connection, but if I do that, it stops detecting the sensor at startup.

The other problem is that leaving it uncalibrated, I try to command it with the Android app. It lets me do it once, and then it doesn't respond anymore.

It's all quite complicated, a big challenge.

Gustavo, I assembled an MK3 and went through a lot of chaos at first. I stumbled into several ways to get things reversed or incorrectly initialized. One of your issues triggered a dim memory of one I had. In regard to the problem of having the elevation value decrease instead of increase as expected, could it be due to the 45 degree position you chose at assembly (for the mid range potentiometer setting)? Depending upon the 45 degree position you pick, the resistance will either go up or down as you approach 0. Just a thought. Good luck!

Gustavo has reacted to this post.

Thanks for responding. Well, I'm making progress with the trial and error method. There are two issues I can't solve. I can't get the azimuth sensor value to be a linear reading, and secondly, from the controller's own web page, I can only make it move once by entering the values (azimuth and elevation) myself. When I try for the second time, it doesn't respond anymore. I'll keep trying everything within my reach.

Hello. Well, I'm updating you on my progress.
The main issue at the moment is with the azimuth sensor. I measured the potentiometer with a multimeter, and it's perfect, but it gives me non-linear readings in Satran. There are significant jumps in the values, making it impossible for me to calibrate the azimuth.
I've already modified the wiring without success.

I'm reaching out to see if anyone else can help me.

Thank you!

Page 1 of 2Next